Can I install this to an instance

Jun 22, 2011 at 5:57 PM

Reading through the directions - I did not really think I saw the option to install this to a named local instance - my local instance is (local)\Doug - not (local).

Thanks for your help,

Doug

Jun 22, 2011 at 6:24 PM

Got it going TST- tst /server localhost/Doug

Trying to run the default tests - tst /Runall localhost/Doug I see this:

HResult 0x2, Level 16, State 1
Named Pipes Provider: Could not open a connection to SQL Server [2].
Sqlcmd: Error: Microsoft SQL Server Native Client 10.0 : A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online..
Sqlcmd: Error: Microsoft SQL Server Native Client 10.0 : Login timeout expired.

Ideas?

Doug

Jun 22, 2011 at 7:35 PM

Try this: tst /Runall /server localhost/Doug

Jun 23, 2011 at 2:29 PM

John,

That gave me 'Invalid command line parameters. Unknown parameter: 'localhost/Doug'

So I tried this

tst /Runall /Server localhost/Doug - which is closer, but I get

HResult 0x34, Level 16, State 1
Named Pipes Provider: Could not open a connection to SQL Server [52].
Sqlcmd: Error: Microsoft SQL Server Native Client 10.0 : A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online..
Sqlcmd: Error: Microsoft SQL Server Native Client 10.0 : Login timeout expired.

I have named pipes enabled. I'm about ready to give up.

Doug

Jun 23, 2011 at 3:37 PM
Edited Jun 23, 2011 at 3:41 PM

Replace the ServerName, InstanceName and TestDatabaseName with the right values for your environment and try this:

TST.Bat /Server ServerName\InstanceName /RunAll TestDatabaseName

 

I think the problem you are having is not specifying the test database name. I usually run TST inside SSMS so I sent you down the wrong path with my earlier post. Sorry about that.

 

You also have a slash instead of a backslash between the server name and instance name.